Getting error message 'Exception - Access Violation: C0000005' in the Altiris Agent logs
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Getting error message 'Exception - Access Violation: C0000005' in the Altiris Agent logs

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Article ID: 152895

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Updated On:

Products

IT Management Suite

Issue/Introduction

Recently the customer has noticed the following error message on the Altiris Agent logs:

Exception - Access Violation: C0000005

Example 1: 

Description:
Exception - Access Violation: C0000005
 
Bit Flag: 00000000 - Memory Address Accessed: 00000008 : 0EB0F994
EAX=0EB0FC7C EBX=00000000 ECX=892F79B9 EDX=00000001 ESI=00000007
EDI=00000000 EBP=0EB0FE58 ESP=0EB0FC64 EIP=027E161B FLG=00010202
CS=001B DS=001B SS=0023 ES=0023 FS=0023 GS=003B
 
Stack dump:
 
Stack Trace
027E161B : C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent\InvAgent.dll
 
 

Example 2:  

Description:
Exception - Access Violation: C0000005
 
Bit Flag: 00000000 - Memory Address Accessed: 00000FFC : 07AACBF0
 
EAX=00000FFC EBX=00000FFC ECX=00000007 EDX=00000073 ESI=03572CFA
EDI=7FFFFFFE EBP=07AACF64 ESP=07AACED8 EIP=035486C5 FLG=00010202
CS=001B DS=001B SS=0023 ES=0023 FS=0023 GS=003B
Stack dump:
 
Stack Trace
035486C5 : C:\Program Files\Common Files\Altiris\AeXNetComms.dll

 

Cause

Known Issue. There is an access violation in the Altiris Agent when it is trying to log a debug message that includes a stack trace.

Resolution

This issue has been reported to the Symantec Development team. A fix for this should be provided a future release.

The current workaround for many customers is to restart the Altiris Agent service when the issue occurs. As well there is a plan on providing a pointfix Altiris Agent that will address this problem.

See HOWTO36013 "Symantec Management Platform 7.0 SP5 Pointfixes Rollup Information Notes" for the list of most current fixes and newer version of the Altiris Agent.


Applies To

Symantec Management Platform 7.0 SP5
Symantec Management Agent 7.0.8641