Altiris Agent GUI will not open via terminal services due to registry setting “Run UI in Main Session Only”
search cancel

Altiris Agent GUI will not open via terminal services due to registry setting “Run UI in Main Session Only”

book

Article ID: 152888

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

When a managed computer has the registry value "HKLM\Software\Altiris\Altiris Agent\Run UI in main session only" set to 1, the following will occur during terminal sessions:

  • The Altiris Agent icon will remain hidden in the system tray even though the agent’s configuration policy is set to have the icon visible.
  • The Altiris Agent GUI will not open after running AexAgentActivate.exe through the remote session. 

Cause

The Altiris Agent is working as designed.

Resolution

“Run UI in main session only” ensures the Altiris Agent icon is only available in the console session (session 0) by prohibiting AexAgentUIHost.exe from loading for each user. See related article 3443. If you attempt to open the Altiris Agent GUI you will see the following informational entry in the agent’s logs:

Priority: 4

Date: 6/22/2006 9:33:55 AM

Tick Count: 1119774734

Host Name: NS01

Process: AeXAgentActivate.exe (1560)

Thread ID: 2400

Module: AeXAgentActivate.exe

Source: AeXAgentActivate

Description: Not starting UI session for TS session 1, the UI is configured to run in console mode only