Missing WinPE optional components for selection while using Boot Disk Creator
search cancel

Missing WinPE optional components for selection while using Boot Disk Creator

book

Article ID: 152836

calendar_today

Updated On:

Products

Ghost Solution Suite Deployment Solution

Issue/Introduction

When creating a new WinPE boot disk using Boot Disk Creator there are missing WinPE packages (optional installable components) on STEP 7 of 8. Other symptoms may include the inability to add drivers.

Note: This may cause the DAgent in WinPE automation fails to connect to the Ghost Solution Suite server with the message: Unable to connect with DAgent for status updates

As seen in the screenshot below, the WinPE packages are missing:

Environment

GSS 3.x

Cause

This issue is most commonly caused by corruption in WinPE/ADK installation.

In some cases this can be caused by limited rights to C:\Windows\Temp which is a staging area for the Boot Disk Creator builds.

Resolution

To overcome this issue do the following:

  1. Try closing the window and then reload Boot Disk Creator & restart ALL services

  2. Uninstall/reinstall the WinPE ADK and PE add-on and re-import these to Boot Disk Creator. These steps should be performed by the GSS service account user or a user with Admin rights on the server. Instructions for reinstalling ADK and components are found in this KB article Steps to Re-Import Windows Preboot Operating Systems Into Ghost Solution Suite 3.x

  3. If reinstalling did not help, enable Bootwiz logging using the file bootwiz.ini by following KB article Enable Bootwiz logging for Ghost Solution Suite 3.x. This log should provide further details about what is causing the issue.