Altiris agent service will not start. Access denied errors in agent.log
search cancel

Altiris agent service will not start. Access denied errors in agent.log

book

Article ID: 152793

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Security in a domain or Notification server has changed, now the "Altiris Agent Service" on the Workstation will not start.  In the agent.log you will see errors similar to the following:

 

 <event date='Sep 29 09:26:49' severity='1' hostName='MINAXPGOLD' source='ComService' module='aexnsagent.exe' process='aexnsagent.exe' pid='1180' thread='1212' tickCount='110984' >

  <![CDATA[Unexpected error in ServiceMain: Failed to register class objects: The class is configured to run as a security id different from the caller (-2147467243)]]>

</event>

<event date='Sep 29 09:26:49' severity='1' hostName='MINAXPGOLD' source='AeXAgentActivate' module='AeXAgentActivate.exe' process='AeXAgentActivate.exe' pid='1128' thread='1132' tickCount='111000' >

  <![CDATA[Error activating agent session 0: Access is denied. (-2147024891)]]>

</event>

Unexpected error in ServiceMain: Failed to register class objects: The class is configured to run as a security id different from the caller (-2147467243)

Error activating agent session 0: Access is denied. (-2147024891)

Cause

Security in one of the domains or the notification server changed. Now Workstations are not able to start the Altiris Agent Services.

Resolution

1-      Refer to TECH40842

2-      If the previous doesn’t work giving ( Error activating agent session 0: Access is denied. (-2147024891)) in the agent.log proceed the following:

Go to   START > RUN, type services.msc
find Remote Procedure Call (RPC) in the properties on the (Log on) tab,
Log on as: tick the radio button “Local System account” APPLY
you will be notified that the changes will not take effect till the service is restarted, as a result of not having the authority to restart the service or the tasks of the service are disabled simply restart the operating system.

OR

Open regedit, locate HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AeXNSClient\Security
Delete "Security" binary value subkey.
Restart the computer.

e


Applies To

NS 7 with one or more domains.