Error "Port is Busy: All pipe instances are busy." appears in the ServiceDesk logs
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Error "Port is Busy: All pipe instances are busy." appears in the ServiceDesk logs

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Article ID: 152728

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Updated On:

Products

ServiceDesk

Issue/Introduction

The error logs showed the following errors:  ...could not process timeouts and escalations System.Runtime.Remoting.RemotingException: Port is Busy: All pipe instances are busy.

Server stack trace:

   at System.Runtime.Remoting.Channels.Ipc.IpcPort.Connect(String portName, Boolean secure, TokenImpersonationLevel impersonationLevel, Int32 timeout)

   at System.Runtime.Remoting.Channels.Ipc.ConnectionCache.GetConnection(String portName, Boolean secure, TokenImpersonationLevel level, Int32 timeout)

   at System.Runtime.Remoting.Channels.Ipc.IpcClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)

   at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:

   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

   at LogicBase.Core.Messaging.Remoting.MessagingServer.Get(String session, String exchangeName, Int32 count, ExchangeAttributeQuery[] attributes, MessageQueryType queryType, String attributeToOrderBy, MessageExchangeOrder order)

   at LogicBase.Core.Messaging.RemoteServerImpl.Get(Int32 count, ExchangeAttributeQuery[] attributes, MessageQueryType queryType, String attributeToOrderBy, MessageExchangeOrder order)

   at LogicBase.Core.Models.Workflow.WorkflowExecutionEngine.InternalProcessTimeoutsAndEscalations()

   at LogicBase.Core.Models.Workflow.CheckTimeoutsThread.Invoke()

Cause

This error comes from Microsoft .NET. It appears that a hotfix dll for .NET  Framework 2.0 SP2 was not installed correctly

Resolution


There are a few possible resolutions for this case. Try them in the order listed, and follow each item with a reset of IIS, and a restart of the logicbase 2006 Server Extensions service:

1. Run the following from a command prompt on the ServiceDesk server may also resolve this issue:

          a. aspnet_regiis -k /W3SVC
              (If 'aspnet_regiis -k /W3SVC' doesn't work  run 'aspnet_regiis -ua' twice instead)

          b. aspnet_regiis -i
 
These commands remove .NET and  to reinstalls .NET. These commands may need to be ran directly from the C:\Windows\Microsoft.NET\Framework64\v2.0.50727\   folder.


2. If the above did not work, you will need to apply a .NET hotfix. For details, see the Microsoft article http://support.microsoft.com/kb/971521 for further information.  You will need to contact Microsoft directly to obtain any specific hotfix related downloads. After applying the hotfix, run the following from a command prompt on the ServiceDesk server:

          a. aspnet_regiis -k /W3SVC
              (If 'aspnet_regiis -k /W3SVC' doesn't work  run 'aspnet_regiis -ua' twice instead)

          b. aspnet_regiis -i


Note: ServiceDesk 7.0 MR2 supports .NET 3.5 with any service pack, but does not currently support .NET 4.0. If this is installed, uninstall .NET 4.0. Previous versions of ServiceDesk 7.0 only support up to .NET 3.5 without any 3.5 service packs installed.

3.  If running ServiceDesk 7.1 SP1 or greater on Windows 2008 R2, install Service Pack 1 for Windows 2008 R2.  The service pack includes the 971521 fix listed above.  The page linked to below contains a download link to an Excel document that lists all of the fixes in Windows 2008 R2 SP1 - http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=269

4. Split ProcessManager (keeping SymWebInclude and SymWorkflowPages with the ProcessManager), SD.Feeders and Incident Management into separate application pools. This helps IIS manage these and also limits the effects one application can have on the others.


Applies To

Servicedesk 7.0 or 7.1 on Windows 2003.

ServiceDesk 7.1 on Windows 2008.