Credential check for "<Username>" failed: System.Net.WebException: The remote server returned an error: (503) Server Unavailable
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Credential check for "<Username>" failed: System.Net.WebException: The remote server returned an error: (503) Server Unavailable

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Article ID: 152629

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Updated On:

Products

IT Management Suite

Issue/Introduction

When the customer accesses the Symantec Management Console (SMC), they get the message "Service Unavailable".

Note: Many other things were also not working too.

And, the Altiris logs had messages such as the following:

Priority: 2
Host Name: ServerName
Process: AtrsHost (1912)
Thread ID: 3
Module: AtrsHost.exe
Source: Altiris.TaskManagement.ClientTask.*
Description: NotificationServerWebConnection.FigureOutCredentials(): Credentials in Agent registry were invalid, or there was an error connecting to the server.

Priority: 2
Host Name: ServerName
Process: AtrsHost (1912)
Thread ID: 3
Module: AtrsHost.exe
Source: Altiris.TaskManagement.ClientTask.*

Description: NotificationServerWebConnection::CheckCredentials(): Credential check for "altirissvc" failed: System.Net.WebException: The remote server returned an error: (503) Server Unavailable.
at System.Net.HttpWebRequest.GetResponse()
at Altiris.ClientTask.Server.Communication.NotificationServerWebConnection.PostToNotificationServer(String url, ICredentials credentials, NSWebConnectionBuildRequestStreamDelegate requestStreamDelegate, Int32 nMaxAttempts, Int32 nTimeout)
at Altiris.ClientTask.Server.Communication.NotificationServerWebConnection.PostToNotificationServer(String url, NetworkCredential credentials, String postData, Int32 nMaxAttempts, Int32 nTimeout)
at Altiris.ClientTask.Server.Communication.NotificationServerWebConnection.CheckCredentials(NetworkCredential credentials)

Cause

DefaultAppPool is stopped.

Resolution

Start the DefaultAppPool.

Launch IIS manager

  • Start > Administrative Tools > Internet Information Services (IIS) Manager

 

  • In IIS Manager:
    • on left-side:
      • IIS > (local computer) > Application Pools > DefaultAppPool.

check the dot in the lower-left corner of the DefaultAppPool icon

  • if the dot is green the pool has been started
  • if the dot is red the pool is stopped.

If the pool is stopped, then

    • on left-side:
      • right-click on DefaultAppPool
      • Select: start

Now, the dot on the icon should change to green. Wait a few seconds, and make sure the dot remains green.

Note: If the application pool does not stay running,then there is something more going.


Applies To

Symantec Management Platform (SMP) 7