AD Sync hangs in a Running state when "Sync Only Users" is selected.
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AD Sync hangs in a Running state when "Sync Only Users" is selected.

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Article ID: 152531

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Updated On:

Products

ServiceDesk

Issue/Introduction

When you select "Sync Only Users" in Admin > Master Settings > Process Manager Active Directory Settings, the sync process will sync users fine, but then hang in a running state.

Cause

The cause for this is unknown at this time but may be due to the sync process not having been configured to ignore the groups.

Resolution

We are still working to find a resolution to this issue.  As a workaround, you may run the following SQL Script against the Ensemble database which will create a database trigger that will complete the sync once the users are done synchronizing:

Create Trigger CompleteADSyncProcess

on ActiveDirectoryServer

FOR UPDATE

AS

Update ActiveDirectoryServer

Set SyncProcessStatus = 'Completed',

LastSyncedTime = GetDate()

WHERE SyncProcessStatus = 'Running' and

TotalADUserToBeSynced = SyncedUserCount

NOTE: This is only to be applied if "Sync Only Users" is selected.  You do not want to apply this if you are synchronizing groups as well.


Applies To
Symantec ServiceDesk Solution MR2