"The Cluster service failed to bring clustered service or application <name of the Exchange cluster> completely online or offline" appears in the Event log after the installation of Symantec Mail Security for Microsoft Exchange (SMSMSE)
search cancel

"The Cluster service failed to bring clustered service or application <name of the Exchange cluster> completely online or offline" appears in the Event log after the installation of Symantec Mail Security for Microsoft Exchange (SMSMSE)

book

Article ID: 152491

calendar_today

Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

When a cluster is failed over from the active to passive node, the SMSMSE cluster resource fails.

Symptoms
The following events appear in the Event log of an Exchange 2007 Public folder Single-Copy-Cluster (SCC):

 

    • The Cluster service failed to bring clustered service or application <name of the Exchange cluster> completely online or offline. One or more resources may be in a failed state. This may impact the availability of the clustered service or application
    • The cluster resource host subsystem (RHS) stopped unexpectedly. An attempt will be made to restart it. This is usually due to a problem in a resource DLL. Please determine which resource DLL is causing the issue and report the problem to the resource vendor.
    • Cluster resource 'Symantec Mail Security for Microsoft Exchange' (resource type '', DLL 'c:\program files (x86)\symantec\smsmse\6.5\server\smsmseclusterresource.dll') either crashed or deadlocked. The Resource Hosting Subsystem (RHS) process will now attempt to terminate, and the resource will be marked to run in a separate monitor.”


Conditions:
 

  • SMSMSE Settings file is large.
    On the active node perform the following steps (see below for steps on how to determine the active node):
      1. Open Windows Explorer.
      2. Open the Shared Storage (see steps below for determining the Shared Storage).
      3. Open the SMSMSE folder.
      4. Open the <EVS Name> folder.
      5. See the size of the settings.xml file. If the file is larger than 7MB this condition is met.



 

Cause

During a failover the transfer of the settings.xml file takes a long time when the file size is large. When the time to transfer the file exceeds the timeout this issue occurs. This situation typically occurs when a large number of public folders is written to the settings file. This may also occur if a large number of mailboxes are written to the settings.xml file.

Resolution



Workaround:

SMSMSE 6.0.10 and higher has a workaround whereby the scans can be set up to run on all or none of the mailboxes or public folders. This workaround introduces a limitation so that individual mailboxes or public folders cannot be selected.

Upgrade to 6.0.10 or higher. Then perform the following steps to set up a registry key.
 

    WARNING: In the next steps you edit the Windows registry. Back up the registry before you make any changes to it, because incorrect changes to the registry can result in permanent data loss or corrupted files.
    Modify or delete only the registry keys that are specified.
    For instructions, see the document How to back up the Windows registry.
    1. Add the workaround registry key.
      a. Click Start > Run.
      b. Type regedit.exe and click OK. The registry opens.
      c. Go the registry key:
        Version 6.0.X
          32-bit Operating System: HKLM\Software\Symantec\SMSMSE\6.0\Server
          64-bit Operating System: HKLM\Software\Wow6432Node\Symantec\SMSMSE\6.0\Server
        Version 6.5.X
          32-bit Operating System: HKLM\Software\Symantec\SMSMSE\6.5\Server
          64-bit Operating System: HKLM\Software\Wow6432Node\Symantec\SMSMSE\6.5\Server


      d. Right click on the Server key and select New > DWORD Value.
      e. Name the new key DisScanItemList.
      f. Double-click DisScanItemList. A window opens that allows you to change the Value data.
      g. Give it the value of '1' (without the quotation marks).
      h. Click OK to close the window.
      i. Exit the registry.
    2. Remove the SMSMSE settings.xml file.
      a. Open Windows Explorer.
      b. Open the Shared Storage (see steps below for determining the Shared Storage).
      c. Open the SMSMSE folder.
      d. Open the <EVS Name> folder.
      e. Remove the file settings.xml file.

    3. Restart the Symantec Mail Security for Microsoft Exchange Service.






Technical Information
Steps to determine Shared Storage used by SMSMSE resource

 

    1. Open Cluster Administrator.
    2. Expand Groups.
    3. Expand the Exchange Virtual Server(EVS) group.
    4. In the right-pane, right-click the SMSMSE resource and click Properties.
    5. Select the Dependencies tab.
    6. You will see two dependencies, a Network Name and a type of disk dependency.
    7. Select the disk dependency and click Properties.
    8. Select the Parameters tab.
    9. This is the drive letter of the Shared Storage the SMSMSE resource is using.


To determine the active node
 

    1. Open Cluster Administrator.
    2. Expand Groups.
    3. Expand the Exchange Virtual Server group.
    4. In the right-pane you column called Owner. The computer listed in the owner column is the Active Node.