Unable to start Symantec Mail Security for Microsoft Exchange. Error Message: "The Symantec Mail Security for Microsoft Exchange service could not be started." when Operating System File rpcns4.dll is Missing
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Unable to start Symantec Mail Security for Microsoft Exchange. Error Message: "The Symantec Mail Security for Microsoft Exchange service could not be started." when Operating System File rpcns4.dll is Missing

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Article ID: 152478

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

The Symantec Mail Security for Microsoft Exchange (SMSMSE) service fails to start and errors are written to the application event log.

Symptoms
When attempting to start the service via the command prompt you receive the error "The Symantec Mail Security for Microsoft Exchange service could not be started. The service did not report an error."


 

  • This may occur directly after installation of SMSMSE.



Conditions:
 

  • In the application event log, you will see the following events:
    Event Type: Error
    Event Source: Symantec Mail Security for Microsoft Exchange
    Event Category: Error
    Event ID: 110
    Description:
    The process SAVFMSEUI.EXE failed to start (0xC009008A).

    Event Type: Error
    Event Source: Symantec Mail Security for Microsoft Exchange
    Event Category: Service
    Event ID: 28
    Description:
    Service failed to start. Check the log for other errors.
  • If you enable the "LogAllFailures" key as per this document: 'How to Obtain a DebugView Log File From Symantec Mail Security for Microsoft Exchange (SMSMSE)' you will also see the following events during attempted service start:
    Event Type: Information
    Event Source: Symantec Mail Security for Microsoft Exchange
    Event Category: Error
    Event ID: 170
    Description:
    Process: SAVFMSESrv(1344), File: \ServiceMgr.cpp, Line: 914: HRESULT=0x1 - Incorrect function.

    Event Type: Information
    Event Source: Symantec Mail Security for Microsoft Exchange
    Event Category: Error
    Event ID: 170
    Description:
    Process: SAVFMSESrv(1344), File: \ServiceMgr.cpp, Line: 232: HRESULT=0xC009008A

    Event Type: Information
    Event Source: Symantec Mail Security for Microsoft Exchange
    Event Category: Error
    Event ID: 170
    Description:
    Process: SAVFMSESrv(1344), File: \NAVEApi.cpp, Line: 289: HRESULT=0xC009008A
  • If you obtain a Process Monitor log file during attempted service start, you will see entries similar to the following:
    Process Name Operation Path Result
    SAVFMSEUI.EXE QueryOpen C:\Program Files (x86)\Symantec\SMSMSE\6.0\Server\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\WINDOWS\SysWOW64\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\WINDOWS\system\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\WINDOWS\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\WINDOWS\SysWOW64\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\Program Files\Support Tools\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\WINDOWS\SysWOW64\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\WINDOWS\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\WINDOWS\SysWOW64\wbem\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\WINDOWS\SysWOW64\windowspowershell\v1.0\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\Program Files\Microsoft\Exchange Server\Bin\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\Program Files\Microsoft\Exchange Server\Scripts\RPCNS4.dll NAME NOT FOUND
    SAVFMSEUI.EXE QueryOpen C:\Program Files (x86)\ExchangeMapi\RPCNS4.dll NAME NOT FOUND


 

  • If you look in the C:\Windows\System32 directory, no file named rpcns4.dll exists.




 

Cause

rpcns4.dll, a core Windows OS component on which SMSMSE is dependant is missing.

Resolution

To correct this issue, replace the file rpcns4.dll in the C:\Windows\System32 directory with a copy from a working server of the same operating system. If you do not have another server with the same operating system, or are uncomfortable taking these steps, please contact Microsoft for assistance with this OS .dll file.


References
When Clicking Reports in the Symantec Mail Security for Microsoft Exchange (SMSMSE) Console Error Message is displayed: "No connection could be made because the target machine actively refused it 127.0.0.1:58081"