Running out of disk space because transaction log is too big.
book
Article ID: 152396
calendar_today
Updated On:
Products
Control Compliance Suite Databases MS SQL SRVRControl Compliance Suite UnixControl Compliance Suite Databases OracleControl Compliance Suite NetwareControl Compliance Suite ExchangeControl Compliance Suite Windows
Issue/Introduction
Running out of disk space because transaction log is too big.
Symptoms Hard disk has 0 bytes free.
Cause
When Control Compliance Suite is installed, all the CCS databases are configured to use Full recovery model. This requires that the database and transaction log files are regularly backed up. When the transaction logs are too big and the disk runs out of space, SQL may mark the database as suspect because of the lack of space for the transaction log expansion.
Resolution
Note: Please backup all the affected SQL databases (including transaction logs) before proceeding.
Make sure that all Control Compliance Consoles are closed.
Open SQL Server 2005 Management Studio. and connect to the SQL server hosting the Contol Compliance Suite databases.
Click on File | New | Query with Current Connection
Set the database recovery model to Simple by running the following t-SQL command
ALTER DATABASE "database_name" SET RECOVERY SIMPLE
Right click on the affected database and click on Tasks | Detach...
Click on OK.
Go to the directory where the CCS database files are located (default location: C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data).
Rename the *.ldf file for the affected SQL database.
Go back to the SQL Server 2005 Management Studio.
Right Click on Databases | Attach...
Click on Add on Attach Databases screen,
Browse to the affected database and select it. Click on OK.
In "Database details" section, select the transaction log file and click remove.
Click on OK to attach the database. This will create a new transaction file.