How to add a license (slf file) to CCS using the "Symantec.CSM.LicenseUtil"
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Article ID: 152312
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Updated On:
Products
Control Compliance SuiteControl Compliance Suite Standards ServerControl Compliance Suite Standards ModuleControl Compliance Suite Standards DatabaseControl Compliance Suite Directory Services
Issue/Introduction
Unable to add license through the CCS console because the Application Server Service will not start due to the core license(s) have expired.
Environment
CCS 12.6.x - 12.7
Cause
Control Compliance Suite (CCS)
The CCS license has expired before entering in the new licenses in the CCS Console
Resolution
How to add CCS licenses when that Application Server service will not start:
Log in as the CCS Service Account or a user that has the CCS Administrator role.
Run the <install directory>\Symantec\CCS\Reporting and Analytics\Directory Support Service\Symantec.CSM.LicenseUtil.exe utility on the Application Server.
Select the 'Add Licenses' button.
Browse to the CCS licenses (unzip the license file before selecting the license)
Select the new license .slf file(s) (you can select multiple .slf files or add them just one at a time).
After the license(s) are added, the Status should reflect that the license(s) have been added successfully.
Start the Application Server Services (and any other CCS services that are not started)