Log error: The specified resource is not ready
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Log error: The specified resource is not ready

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Article ID: 152306

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Updated On:

Products

IT Management Suite

Issue/Introduction

You have just rolled out the Symantec Management Agent (Altiris Agent or SMA) and the client doesn't seem to be receiving any policies. After checking the NS logs, the following message appears:

RequestPolicies failed: Unexpected response from URL HTTPS://SMPServer.example.com/ALTIRIS/NS/Agent/GetClientPolicies.aspx?xml=<Request configVersion="2"><WrkstaGuid>{xxxxxxxx-CC35-41C0-A4E3-4D0E9E8F2CCA}</WrkstaGuid></Request>&compress=1&hash=1: The specified resource is not ready. This condition is temporary and will be resolved as soon as the next collection update occurs (Resource: {xxxxxxx-cc35-41c0-a4e3-4d0e9e8f2cca}) (-2147213299)

and under the Agent log:

<event date='10/17/2024 18:41:56.8960000 -04:00'
severity='1' hostName='<<COMPUTER>>' source='PackageDelivery' module='AeXPackageDelivery.dll' process='AeXNSAgent.exe' pid='3340' thread='3024' tickCount='13087000' >
  <![CDATA[Error while downloading package: The specified resource is not ready. This condition is temporary and will be resolved by the next collection update]]>
</event>

Environment

ITMS 8.7.x

Cause

The log message indicates that the resource (Altiris Agent) has been discovered, but the Filters (previously known as Collections) that refer to it have not yet been updated.

To calculate which policies apply to an agent, the SMP Server first needs to know which Filters contain the agent. Once it knows which Filters contain the agent it can then work out which active (enabled) policies apply to these Filters and to the agent. The SMP Server is waiting for a Resource Update to occur so that it can determine what active policies apply to the resource (agent).

Resolution

To work out which Filters contain an agent we require Basic Inventory to run from an agent, then this information allows the SMP Server to determine which Filters the agent should be a member of. The Resource Membership Update's schedules control how often the Filters are updated.

The options provided by the Resource Membership Update page are:
  • Complete Update Schedule
  • Delta Resource membership Update
  • Policy Filter Update

There is a small window of opportunity from when a computer first sends Basic Inventory and when the filters are updated. During this time, you will receive the message "The resource is not ready." However, once the Filters have been updated, you will not receive this message again for the specified agent. If at this point you are still not getting policies, you should check that you have enabled any needed policies and that you have applied them to a Filter(s) that includes the agent in question.


You can find the options for updating filter membership and policy -> filter associations by:

1) Open the Symantec Management Console
2) Navigate to Settings -> Notification Server -> Resource Membership Update
3) On Complete Update Schedule, click: Run.

This will update the membership for all Filters, Organizational Groups, and Targets


Check in the SMP Console interface to confirm that these three tasks are scheduled to run. The following are the defaults:

  • Delta update schedule repeats every 5 minutes
  • Complete update schedule repeats once a day
  • Policy update schedule repeats every 5 minutes

If you continue to experience difficulties, check the Notification Server logs to confirm that these jobs are running periodically and as expected.

  • To find when the Delta Update task ran, search on:
    • Source = Altiris.NS.StandardItems.Targeting.ResourceTargetDeltaUpdateSchedule.OnSchedule
    • Message Severity = Informational
  • To find when the Complete Update task ran, search on:
    • Source = Altiris.NS.StandardItems.Collection.AlwaysRefreshCollectionUpdateSchedule
    • Message Severity = Informational
  • To find when the Policy Update task ran, search on:
    • Source = Altiris.NS.StandardItems.Collection.DeltaCollectionUpdateSchedule
    • Message Severity = Informational and Trace