Unable to create Software Update Policies. Failed to initialise SoftwareUpdateAdvertismentSetPolicy.
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Unable to create Software Update Policies. Failed to initialise SoftwareUpdateAdvertismentSetPolicy.

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Article ID: 152261

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Created Software Update Policy on the Patch Remediation Center. Wizard opens, worked through Filter selection, and selected 'Distribute Software Updates', but the Policy is not created.

Received the following errors in the NS Logs:

  • Source: Altiris.PatchManagementCore.Policies.SoftwareUpdateAdvertismentSetPolicy.Initialise
    Description: Failed to initialise SoftwareUpdateAdvertisementSetPolicy -> 'Software Installation Options cannot be set. Empty Program definition'
  • Source: Altiris.PatchManagementCore.Policies.SoftwareUpdateAdvertisement.SetDefaultAdvertisementDetails
    Description: Failed to set installation options as program is not defined. Possibly trying to distribute not staged update

Cause

The configuration commands are run out of order.

This may be caused during the upgrade for there may have been a failure during the process of running one of the commands.

Resolution

Reconfigure Patch Management Solution to the Symantec_CMDB Database:

Note if any Patch related point fixes are applied you will need to re-apply them after reconfiguring Patch 

  1. Log into the Notification Server using the Application Identity (Service) account 
  2. Open the Symantec Installation Manager (SIM)
    1. If SIM prompts to upgrade, initiate the upgrade (upgrades SIM only)
  3. Click the Repair installed products link
  4. Click Reconfigure installed products and Next
  5. Check the box for Altiris Patch Management Solution 8.x (RUx as applicable) and Next
  6. Click Configure

If you find this does not resolve the issue, repeat these steps again by select Repair in step 4 and then repeat a Reconfigure