Error "The transaction log for database 'Ensemble' is full." occurs in ServiceDesk
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Error "The transaction log for database 'Ensemble' is full." occurs in ServiceDesk

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Article ID: 152235

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Updated On:

Products

ServiceDesk

Issue/Introduction

When trying to access ServiceDesk, the following error message occurs:

The transaction log for database 'Ensemble' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases

Creating new tickets may also fail to work or result in the above error.

Cause

The transaction log of the Ensemble database is full.

Resolution

Use one of the following three methods to truncate the transaction log, then change the SQL recovery method for the Ensemble DB to Simple.

  1. Make a full backup from the Ensemble database, this will truncate the transaction log.
  2. Maintain the Ensemble database the following article:

    Creating a maintenance plan in SQL Server 2005 or 2008 to optimize database performance
    http://www.symantec.com/business/support/index?page=content&id=HOWTO8589
     
  3. Truncate the transaction log manually:
    To truncate the current transaction logs do the following.
     
    a. Open SQL Server Management Studio on the ServiceDesk's SQL server.
    b. Click on the New Query button in "SQL Server Management Studio"
    c. Paste the following into the first SQL query tab.
     
    Use Ensemble
    BACKUP LOG "Ensemble" WITH TRUNCATE_ONLY
    DBCC Shrinkfile('Ensemble_Log',truncateonly)
     
    d. Click on the Execute button.
     
Now change the SQL recovery method for the Ensemble DB to Simple. This will prevent the transaction logs from filling in the future.
Warning: As a precaution backup the SQL ensemble Database before performing the instructions below.
 
  1. Open SQL Server Management Studio on the ServiceDesk's SQL server.
  2. Go to SQLserverName > Databases > Ensemble.
  3. Right click the Ensemble DB and click Properties.
  4. Click Options.
    Note:IF the recovery model is set the full then do the following.
     
  5. In the Recovery Model dropdown change the model from Full to Simple.
  6. Close the Database Properties by clicking OK.

For more information on truncating the transaction log, please refer to the following article:
 
How to shrink the Notification Server transaction log
http://www.symantec.com/business/support/index?page=content&id=HOWTO1752


Applies To

Service Desk 7.0