KNOWN ISSUE: "Index was outside the bounds of the array" when using Submit Advanced Incident form
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KNOWN ISSUE: "Index was outside the bounds of the array" when using Submit Advanced Incident form

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Article ID: 152225

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Updated On:

Products

ServiceDesk

Issue/Introduction

After using the Submit Incident (Advanced) form to create a new incident i get the following error in the portal when i click the Submit button:

Error Message:
Index was outside the bounds of the array.
 
Message Stack:
at System.Array.InternalGetReference(Void* elemRef, Int32 rank, Int32* pIndices)
at System.Array.SetValue(Object value, Int32 index)
at System.Collections.Hashtable.CopyKeys(Array array, Int32 arrayIndex)
at LogicBase.Core.Data.OrchestrationData.get_RootNames()
at LogicBase.Core.Data.OrchestrationData.Commit()
at LogicBase.Core.Models.Dialog.AbstractDialogExecutionEngine.HandleCleanup(TLExecutionContext context)
at LogicBase.Core.ExecutionEngine.AbstractExecutionEngine.RunEngine()
at LogicBase.Core.Models.Dialog.AbstractDialogExecutionDelegate.FollowLink(AbstractDialogExecutionEngine engine, DialogState state, IMultiPathComponent component, IData data, String path)
at LogicBase.Core.Models.Dialog.ASPXTerminateDialogExecutionDelegate.HandleEndInteraction(AbstractDialogExecutionEngine engine, ComposerForm page)
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Cause

This is due to the out of the box configuration of Workflow Server.  It stores session information in memory and it is therefore lost after an IIS reset or recycling of the application pool. 

Resolution

Upgrade to ServiceDesk 7.0 MR2


Applies To
ServiceDesk Solution 7

ServiceDesk Solution 7 MR1