AXEngine/aclient reporting WSAECONNABORTED errors: Axengine and PXE services hangs
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AXEngine/aclient reporting WSAECONNABORTED errors: Axengine and PXE services hangs

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Article ID: 152213

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Updated On:

Products

Deployment Solution

Issue/Introduction

When a client computer launches BootWorks to begin an imagining process, they hang at "Updating Client Record". Clients also do not stay connected or PXE Services fails.  The AxEngine log contains the following kinds of errors:

1696-OnWSANotify() called with an error of: WSAECONNABORTED

The source is the Service Control Manager, the Event ID: 7034 and the description is:
The Altiris PXE Services service terminated unexpectedly.

Cause

WSAECONNABORTED is a Microsoft error. If a Google search is performed, a number of hits will be found:

WSAECONNABORTED (10053) Software caused connection abort. The software caused a connection abort because there is no space on the socket's queue, and the socket cannot receive further connections.

WinSock description:  The error can occur when the local network system aborts a connection. This would occur if WinSock aborts an established connection after data retransmission fails (receiver never acknowledges data sent on a datastream socket).

TCP/IP scenario: A connection will timeout if the local system doesn't receive an (ACK)nowledgement for data sent. It would also timeout if a (FIN)ish TCP packet is not ACK'ed (and even if the FIN is ACK'ed, it will eventually timeout if a FIN is not returned).

Resolution

AClient settings on each computer and the client were configured to Remain Connected and Refresh Connections every 14400 seconds. Removed the Refresh Connections option and rebooted the server. Use Article 4214 to check these settings.

 

Article ID: 41040 Best practice for Aclients 6.5-6.9 to refresh their connection with the Deployment Server. If you enable the logging level for Deployment Server to level 5 you will see these errors. Control Panel> Deployment Server Configuration> Options> Debug.

The Deployment server Services may need to be restarted.

You may also need to refer to the following Microsoft KB article -

View the Axengine.log set to level 5>

Error code when you run a network program that uses a Winsock connection on a computer that is running Windows Server 2003: "WSAECONNABORTED (10053)"

http://support.microsoft.com/kb/931319/en-us

This Fix may need to be applied to both the Deployment Server and the Clients.

The aclient.log will show the following Socket: Closing socket (12304) due to error (10053, WSAECONNABORTED).

View Aclient.log will show computer that is running Windows XP The same type of error will appear on the Client side (10054, WSAECONNRESET ) visible in the aclient.log

 

http://support.microsoft.com/kb/938566/en-us

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:
http://go.microsoft.com/?linkid=6294451

for WSAEWOULDBLOCK in the axengine.logs Contact Support for DS 6.9.964


Applies To
Deployment Solution 6.1-6.9