No license files found—license files must have a extension of .txt
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No license files found—license files must have a extension of .txt

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Article ID: 152208

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Updated On:

Products

IT Management Suite

Issue/Introduction

On an installation of NS 6.0 SP2 when trying to install licenses, the following error is received when pointing to a license folder path:

No license files found (note, license files must have a ".txt" extension)

If you try to cut and paste the license and test it that way you get the following error:

Unable to install the certificate. Please obtain a valid license and try again.

Cause

Possible issue with Hotfix 19.

Resolution

You can try two things:

First, go to the Licensing page and click Refresh even though you got the error about No licenses files found. This should refresh the page and the proper XML files used by Licensing.

Second, previously the resolution was obtained by:
  1. Removing Hotfix 19 via Add or Remove Programs.
  2. Installing the licenses.
  3. Then reinstalling Hotfix 19 by right clicking on <Installation Path>\Altiris\Setup Files\NS\Altiris_SP_HotFix_0019.msi and choosing the install option.

This would correct the license count shown although future licenses additions would still result in the same error.

Note: Upgrading to the latest build of NS SP3, which was the latest release when this article was published, resolved the issue.


Applies To
NS 6.0.5287 (SP2) with Hotfix 19