Cannot connect to the SQL database after rebuilding the Symantec Endpoint Protection Manager. SQLState: '01000' and '08001' are returned.
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Cannot connect to the SQL database after rebuilding the Symantec Endpoint Protection Manager. SQLState: '01000' and '08001' are returned.

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Article ID: 152173

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Updated On:

Products

Endpoint Protection

Issue/Introduction

You are unable to connect to the SQL database after rebuilding the Symantec Endpoint Protection Manager.
SQLState: '01000' and '08001' are returned when you test the connection from ODBC

As a result of not being able to connect to the database you will also get messages with the error "Unable to communicate with the reporting component" after logging in to the SEPM.

 

The following error message is returned when testing connection to the DB from ODBC.

Connection failed:
SQLState: '01000'
SQL Server Error: 14
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Invalid Instance()).
Connection failed:
SQLState: '08001'
SQL Server Error: 14
[Microsoft][ODBC SQL Server Driver][DBNETLIB]Invalid connection.

Cause

There are two possibilities:

  1. The instance name that is configured is not correct for the SEP Database
  2. The instance name is correct, but "Dynamically Determine port" option is checked

Resolution

To check the On the Symantec Endpoint Protection Manager, proceed to Start> Administrative Tools> Data Sources (ODBC).

  1. Proceed to the System DSN tab within the ODBC Data Source Administrator.
  2. Double-click on SymantecEndpointSecurityDSN.
  3. Confirm that the appropriate SQL Server (and instance) is specified in the Server box, and click on Next.
  4. Click on Client Configuration.
  5. Uncheck the Dynamically determine port box.
  6. Click on OK.
  7. Select the "Test Connection" button to confirm the configuration is correct.
  8. Restart the Symantec Endpoint Protection Manager.