Symantec Brightmail Gateway appliance hardware platforms receive an Error within the Battery column on the Hardware Status screen
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Symantec Brightmail Gateway appliance hardware platforms receive an Error within the Battery column on the Hardware Status screen

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Article ID: 152141

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Symantec Brightmail Gateway appliance hardware platforms receive an Error within the Battery column on the Hardware Status screen.
 

You notice within the Hardware Status screen, an Error within the Battery column. Notifications may be present within SNMP traps, Dell Remote Access Controller (DRAC) logs, and/or LED display indicating battery warning.

Cause

Commonly this is caused while the RAID Controller rebuilds the NVRAM cache resources. During this time, the RAID Controller's Battery can be discharged and recharged for battery reconditioning. This normally happens every three to six months. This issue becomes critical if the RAID Controller's Battery has electrical charge issues or the RAID Controller has issues recognizing the battery.

Resolution

A diagnostics analysis may need to be done to discover the cause. If the server is under dell warranty, a trained Symantec Technical Support professional might be able to ascertain the cause and provide the necessary steps to assist you.

Found within diagnostics, the Messages.txt log will be reviewed for the behavior of the RAID Battery operations.

Normal Error Notification Behavior
Below behavior reflects that the battery is under recondition period. The Symantec Brightmail Gateway will report error status on the Control Center's Hardware Status screen when the battery reaches below 50%. The reporting interval for "SMS::Hardware: BATTERY in Failure state, charge" is five minutes. Normal operation behavior will show charge decrease and eventually increase as reflected in the example below.

NOTE: Other OS level details will be included, the below example only lists SMS::Hardware details.

<diagnostics filename>/logs/messages.txt Log

<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 48%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 43%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 39%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 34%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 30%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 26%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 22%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 17%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 10%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 16%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 21%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 27%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 32%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 38%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 43%
<date & time> (crit) SMS::Hardware: BATTERY in Failure state, charge = 48%


The command line interface can be used to allow a short review of the messages log.
 

  1. Log in to the command line interface via putty or other SSH client using the "admin" account
  2. Type the command: "tail messages"


Critical Behavior
If the notice indicates SMS::Hardware: BATTERY in Failure state, charge = NOSUCHINSTANCE% or the notice does not discontinue after returning to 40% range, it is possible a hardware failure has occurred. Please contact Symantec Technical Support to have the issue evaluated.



Technical Information
Per Dell’s document for the PERC 5 (PowerEdge Expandable RAID Controller) Battery Management -- How Firmware Manages Cache, “Firmware manages cache based on the condition of the battery. Learn Cycle is a battery calibration operation performed by the controller periodically (approximately every 3 months) to determine the condition of the battery.


http://support.dell.com/support/edocs/storage/RAID/PERC5/en/UG/HTML/chapterb.htm#wp1057338


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