Installation or a Scripted install returns Error 3010 exit code in Deployment Server, Patch Management, Software Delivery or Ghost Solution Suite
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Installation or a Scripted install returns Error 3010 exit code in Deployment Server, Patch Management, Software Delivery or Ghost Solution Suite

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Article ID: 152125

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Updated On:

Products

IT Management Suite Deployment Solution Ghost Solution Suite

Issue/Introduction

Installation of an MSI package returns Error 3010 but the exact cause of the error is unknown

Environment

ITMS 7.x, 8.x

GSS 3.x

Cause

Most MSI return or error codes are predefined by Microsoft. ITMS and GSS are designed to display these return/error codes in the job/task status upon completion.

Resolution

What does error 3010 mean?

3010

The requested operation is successful. Changes will not be effective until the system is rebooted.

ERROR_SUCCESS_REBOOT_REQUIRED

This isn’t really an error but is just a code stating that the operation completely successfully and requires a reboot to become effective.

What Switch is causing the problem?
The problematic switches in many of the scripted install process are:/q, /q:a, /z, /r:n.

These switches either suppress the prompt that tells the user that they need to reboot the computer for the install to finish or force the install without a reboot.

Explanation:

As an example: an install of service pack 3 completes with no problem using the -q -z -o switches. However when using using /q:a /r:n with an installation of any update, the installation completes but returns the error code 3010.
Common Command-Line Switches for Self-Installing Update Files (Software may not support all switches listed here):
 

/q

Specifies quiet mode, or suppresses prompts, when files are being extracted.

/q:u

Specifies user-quiet mode, which presents some dialog boxes to the user.

/q:a

Specifies administrator-quiet mode, which does not present any dialog boxes to the user.

/r:n

Never restarts the computer after installation.

/r:i

Prompts the user to restart the computer if a restart is required, except when used with /q:a.

/r:a

Always restarts the computer after installation.

/r:s

Restarts the computer after installation without prompting the user.

 
Common Switches for Service packs:
 

/f

Force other programs to quit at shutdown

/q

Quiet mode (no user interaction required)

/u

Unattended Setup mode

/z

Do not restart the computer after installation

 
Solution:
 
Force a reboot after the install to finish the installation process within the script use the /f or the /r:a switches.
 
This is not merely a suggestion but a requirement in software delivery as far as Technical Support is concerned.
 
Two options in dealing with this error:
  1. Remove the /q:a or /q from the command line used. This will stop the occurrence of the 3010 error and then force the reboot of the client machine.
  2. Use Error handling within your scripts to work through that error. If with Software Management, add 3010 and 0 to the success codes in order to properly report a success
Here is a script example:
REM Installing Hotfix MS03-026
\\ServerName\express\server\common\packages\hotfix\q823980\q823980w2k.exe /u /z /q
if ERRORLEVEL 3010 goto success
if ERRORLEVEL 0 goto success
 goto failure
:success
set %ERRORLEVEL% = 0
goto end
:failure echo Failed
EXIT 1
#goto
end
:end