Error "System.Exception: Could not read in object" occurs when running a ServiceDesk or Worflow project
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Error "System.Exception: Could not read in object" occurs when running a ServiceDesk or Worflow project

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Article ID: 152045

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Updated On:

Products

ServiceDesk

Issue/Introduction

When running a ServiceDesk or Workflow project you encounter errors in the log for the project similiar to the one below.

Error,Wednesday, March 03, 2010 1:37:17 PM,User Search failed with the following: Could not read in object   System.Exception: Could not read in object --->
LogicBase.Framework.ObjectDeserializationError: could not deserialize: System.Collections.ArrayList --->
System.Exception: could not find type SD.Components.NotificationServer7Reports.GetAllLocationsComponent
at LogicBase.Framework.ArrayListTypeConverter.GetObject(ObjectStorageContainer storageContainer, ObjectStorageObjectData values, Type valueType, ObjectStorageErrorHandler errorHandler)
at LogicBase.Framework.ObjectReadStream.ReadRelationshipConverter(ObjectStorageValue objValue, Type type, ObjectStorageRelationshipTypeConverter converter)

Cause

This error is caused by the project in question referencing a datatype that cannot be found in the referenced class library.

 

In the example provided, the datatype that cannot be found is SD.Components.NotificationServer7Reports.GetAllLocationsComponent.

The error can be caused by a few different things ranging from corruption of the referenced library to unintended side effects of modifying a custom library. 

Resolution

Resolution of this issue will vary depending on whether the referenced library is an out of the box library or a custom library created through the Integration Component generator or some other means.

If the referenced library is an out of the box component, this issue can be resolved by running an Upgrade install or a repair install.

Note:  Upgrade install is an option for Workflow 7 SP1 and higher and ServiceDesk 7 MR1 and higher.  During the Upgrade install ServiceDesk/Workflow will prompt you to upgrade any libraries or projects it determines are not the proper version.  Workflow 6.5 and lower will require a Repair install.

If the referenced library is a custom library, you will either need to revert the custom library to a prior version or rebuild the library.

Related resources

Known Issue: Replacing libraries when opening a ServiceDesk project will overwrite existing libraries with older or incorrect versions
http://www.symantec.com/business/support/index?page=content&id=TECH127495
 


Applies To

Workflow 6.5
Workflow 7.0
ServiceDesk 7.0