NS Event Queue (EvtQueue) is full - returning BUSY
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NS Event Queue (EvtQueue) is full - returning BUSY

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Article ID: 152012

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Updated On:

Products

IT Management Suite

Issue/Introduction

The  A logs are reporting NS Event Queue (EvtQueue) is full - returning BUSY when there are only approximately 11,000 NSEs in the EvtQueue. Why is this?

Cause

In the HKLM\Software\Altiris\express\Notification Server registry location are a number of keys:

MaxFileQEventCount  - Default is 20000. Indicates that only 20K files are allowed into each queue before the queue is considered full.

MaxFileQSize - Default is 512000 (512K). Indicates the sum of the memory size of all of the NSEs in a queue.

These settings are global for all queues.

 

EvtQueueCurrent Size - The current disk space that the NSEs in the EvtQueue are currently using. There is a similar key for the EvtQFast and EvtQSlow queues.

EvtQueueCurrentCount  - The current count of NSEs in the EvtQueue folder. There is a similar key for the EvtQFast and EvtQSlow queues.

EvtQueueFull- If either the EvtQueueCurrentSize or the EvtQueueCurrentCount exceed MaxFileQEventCount or the MaxFileQSize, the value of this setting is set to 1. The NS will begin reporting that the server is busy because the EvtQueue is full. There is a similar key for the EvtQFast and EvtQSlow queues.

 

In this case, the MaxFileQEventCount was set to 60000 and the MaxFileQSize was set at 512000. Even though only 11000 NSEs were in the EvtQueue, they exceeded the 512MB limitation set by the registry.

Resolution

The MaxFileQSize registry setting value is limited only by the amount of available disk space on the Notification Server. The customer increased the value of this setting to 1512000 (1.5 GB) and the errors went away.

Applies To
NS 6.0 Sp3 R12