VSFlexGrid control errors when trying to access the Notification Server console
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VSFlexGrid control errors when trying to access the Notification Server console

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Article ID: 151987

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Updated On:

Products

IT Management Suite

Issue/Introduction

 I receive a FlexGrid control error when accessing the Altiris Console, or a "GetPicture Failed: Unknown error 0x800C0007" error when opening the Collection Picker. When I go to the Helpdesk Solution, the error stating that component one is not licensed. When I attempt to run reports or view collections, the Notification Server console dialogue displays the following:

FlexGridCtrl: Failed to run GetGridData Web service. Wrong number of arguments or invalid property assignment.

After a moment the report generation or collection refresh terminates with an error box containing the following dialogue:

FlexGridCtrl: Failed to run GetGridData web service. Wrong number of arguments or invalid property assignment 

When I try to open the console, an error (see attached image) that states:

        ComponentOne VSFlexGrid8 [Unicode/Light]
        Version: 8.0.20031.172
        NOT LICENSED.  THIS IS AN EVALUATION VERSION
        You can use this product for a 30-day trial period.

The console will eventually opens up after continuing through the errors.

Cause

The following have been found to cause the FlexGrid and Component One errors:
  • Corrupt FlexGrid ActiveX control
  • Corrupt User profile in Windows

Resolution

In Internet Explorer, go to Tools > Internet Options > Programs tab > Manage Add-ons. In the list, enable ComponentOne FlexGrid. Verify the Internet Explorer* Security settings for the ActiveX controls. Remove the FlexGrid control from the .\Windows\Downloaded Programs directory, and this will re-download the control once the Altiris Console is reopened. To verify that it is completely removed go through the following steps:
  1. Close all open browsers on the system.
  2. Check %WINDIR%\Downloaded Program Files\.
  3. Delete ComponentOne FlexGrid 8.0 (UNICODE Light).
  4. Also, if applicable, remove FlexGrid 7.
  5. Go to Start > Run, type cmd and click OK.
  6. In the command prompt, browse to %Windir%\Downloaded Program Files\. (Generally, from the C: prompt, type cd %windir%, type cd downlo~1).
  7. Do a DIR command.
  8. You may have vsflex files still located in this directory. Delete all instances of it from this command prompt.

Following that, delete the following files from the %windir%\System32 folder on the computer. (These may need to be deleted from other installed instances elsewhere on the hard drive as well.)

AeXMenuCtrlLib.dll
AeXNSConsoleUtilities.dll
AeXNSPkgDLLib.dll
AeXScheduleMgr.dll
AeXTreeCtrlLib.dll

Open the Altiris console again, and the latest version of the console ActiveX components should be downloaded.

In one instance the problem was a corrupt user profile in Windows and using another username for a login on that same computer brought up the console with no errors.

 


Second Option: Run a repair on Helpdesk and Notification Server. If you have a rollup installed for Notification server then you will need to run a repair on the rollup as well.

Related Articles

What ActiveX components are installed and used by Helpdesk and Alert Manager?
http://www.symantec.com/business/support/index?page=content&id=HOWTO7501

Tables in Helpdesk appear with a red "X" or without any table interface
http://www.symantec.com/business/support/index?page=content&id=TECH41818


Applies To

Notification Server 6.0.x
Helpdesk 6.0.x
 

Attachments

VSFlexGridError.jpg get_app