Interactive task failed to start
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Interactive task failed to start

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Article ID: 151979

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Updated On:

Products

IT Management Suite

Issue/Introduction

Interactive (user must be logged on to run) Software Delivery Tasks, including Inventory tasks (User, Recreate User) return a status of "Failed to start" with an exit code of 2147943568. You should also see an entry in the agent.log file like the following:

Date: Jan 20 17:18:36:001
Source: ProgramExec
Description: Failed to launch SWD task 'User Inventory' with command line 'AeXInvSoln.exe /hidden /s AeXInvSolnUsr1.ini': Unable to find running process with interactive user credentials: (-2147023728)

Steps to recreate scenario 1:
  1. Log on to a workstation or server.
  2. Open the Altiris Agent UI window (right-click Altiris icon in systray or run ...\altiris agent\aexagentactivate)
  3. Open Task Manager (Start > Run > "taskmgr.exe")
  4. Select explorer.exe process (this process should show User Name as the user you are currently logged on under), and click End Process button (respond Yes in resulting dialog box).
  5. Run the User Inventory, or Recreate User Inventory, task from the Altiris Agent UI.

Steps to recreate scenario 2:

  1. Log on to a workstation or server.
  2. Open the Altiris Agent UI window (right-click Altiris icon in systray or run ...\altiris agent\aexagentactivate)
  3. Open a Command Prompt window (Start > Run > "cmd.exe").
  4. From that Command Prompt window, schedule a new command window to open in the SYSTEM user context (at <time 1 minute in the future> /interactive cmd.exe).
  5. Wait for the new Command Prompt window to open.
  6. Open Task Manager and End Process on explorer.exe.
  7. From the SYSTEM user Command Prompt window run explorer.exe (c:\>explorer.exe).
  8. Run the User Inventory, or Recreate User Inventory, task from the Altiris Agent UI.

Note: Why this disconnect of the explorer process and the logged on user occurs is not yet determined.

Cause

The NS Agent cannot impersonate the context of the current logged-on user, or locate the explorer.exe process that should be running in the context of the currently logged on user.

Scenario 1: The value for Shell in registry key
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon has been changed from the default Explorer.exe

Scenario 2: The process explorer.exe is not running (should be obvious because no icons, task bar or systray, is visible), or is running as a user other than the logged-on user. This can be confirmed by running Task Manager, locating the explorer.exe, and verifying what User Name is listed beside this process.

Resolution

Ensure that the value for Shell in registry key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon is set to Explorer.exe.

An enhancement (#127252) has been submitted to request the NSAgent process evaluate the Shell value and leverage UI from that executable, if possible. Or to perform a prerequisite check prior to installation and task startup, so if the shell is not one under which we can operate, to notify the user and close gracefully.

Applies To
NSAgent 6.0.1508
Windows XP, 2000, NT4