.CSV files are not importing correctly into collections or the Altiris Agent Installation page
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.CSV files are not importing correctly into collections or the Altiris Agent Installation page

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Article ID: 151977

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

When importing a list of computers in a .CSV file into a collection Include/Exclude or on the Altiris Agent Installation page, the computers do not show up in the list or it seems to not work correctly. 

It may say that 10 out of 50 computers were successfully imported or the like.

Cause

The .CSV file is not formatted correctly; it contains a lot of extra spaces and so on.

Resolution

Make sure that when you open the .CSV file it shows the list of computers going down in a row with no commas or other markings anywhere in the list.

Example:

Computer1
Computer2
Computer3
Computer4
Computer5
Computer6
Computer7
Computer8
Computer9

Many times the problem happens if the file originated as a .XLS file. When saving a file that has additional settings you need to make sure to answer no when prompted to keep the formatting. This will allow the file to save correctly.

An alternate method to fixing the formatting is to copy and paste the list of computers into Notepad and then save it as a .CSV file type. This will work when Excel does not.

One more item of note is that when importing a .CSV file for a collection, it will only add computers that are currently in the database; you cannot populate a collection with computers that have not at least been discovered.

Applies To
Notification Server 6.0