.CSV files are not importing correctly into collections or the Altiris Agent Installation page
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.CSV files are not importing correctly into collections or the Altiris Agent Installation page

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Article ID: 151977

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

When importing a list of computers from a .CSV file into a collection Include/Exclude or to the Altiris Agent Installation page, the computers do not show up in the list or it seems not to not work correctly - saying something like 10 out of 50 computers were successfully imported.

Environment

ITMS 8.x

Cause

The .CSV file is not formatted correctly, as it contains a lot of extra spaces etc.

Resolution

Make sure that when you open the .CSV file it shows the list of computers listing down in a column with no commas or other markings anywhere in the list as shown in the example below:

Computer1
Computer2
Computer3
Computer4
Computer5
Computer6
Computer7
Computer8
Computer9

Many times this behavior happens if the file originated as a .XLS file. When saving a file that has additional settings you need to make sure to answer no when prompted to keep the formatting. This will allow the file to save correctly.

An alternate method to fixing the formatting issue would be to copy and paste the list of computers into Notepad and then save this as a .CSV file type.

NOTE: When importing a .CSV file for a collection, it will only add computers that are currently in the database; so be aware that you cannot populate a collection with computers that have not yet been discovered.