When imaging using Sysprep, receiving error "Sysprep file is missing from the DataStore path"
search cancel

When imaging using Sysprep, receiving error "Sysprep file is missing from the DataStore path"

book

Article ID: 151965

calendar_today

Updated On:

Products

Deployment Solution

Issue/Introduction

When trying to capture or deploy an image of a computer and using Sysprep by checking the box "Prepare using Sysprep,"  users get the error message "Sysprep file is missing from the DataStore path." 

We also saw messages indicating that a file could not be accessed.

Cause

1) When you first install Deployment Server, at the end of the installation wizard, it gives you the option to install Microsoft Sysprep files, but you have to manually check this box before clicking on the Finish button. Usually this issue is caused when this last step is skipped (and Microsoft Sysprep files are not added to the Deployment Server), but it also could be caused if they were installed but then removed or renamed.

2) The “x64” folder in the .\Sysprep\DotNet\ is missing the Deploy.cab file.

3) The ...\eXpress\Deployment Server\Sysprep\DotNet\x86\deploy.cab was corrupted.

Resolution

1) Install or reinstall the Microsoft Sysprep files to the Deployment Server by running the DS installation wizard (Setup.exe) from the DSSetup folder. Select Component Install and then click on Install.

Click Yes to the Software License Agreement, then browse out to the eXpress share on the Deployment Server (this should already be there by default) and click on Next >. Check the box next to Add Microsoft Sysprep files and then click on Next > again. Locate either a Windows 2003 Server, XP, 2000, or NT4 CD and browse out to the file that contains the sysprep file (this is different for each type of Windows CD. See the wizard screen for details) and click Next >. Finally, click on Install and then Finish.

Once this is done, you should be able to run imaging jobs using Sysprep without getting the error message about the Sysprep file missing from the DataStore path.

2) For x64 systems there is no way to import the 64-bit Sysprep deploy.cab in the DS installation. Instead create an “x64” folder in the .\Sysprep\DotNet\ directory and copy the deploy.cab from the 2K3 64-bit CD.

3) Send a default version of \eXpress\Deployment Server\Sysprep\DotNet\x86\deploy.cab

Applies To
Deployment Solution 6.5 through 6.9, all versions.