Error "An error while attempting to run the scheduled job" in Control Compliance Suite 12.x
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Error "An error while attempting to run the scheduled job" in Control Compliance Suite 12.x

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Article ID: 151894

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Updated On:

Products

Control Compliance Suite Windows Control Compliance Suite Control Compliance Suite Standards Server Control Compliance Suite Unix

Issue/Introduction

Control Compliance Suite (CCS)

When running a data collection (DC) or collection-evaluation-reporting (CER) job in CCS, you get the following message:

An error occurred while attempting to run the scheduled job.

Reason for failure: Password does not exist for user '<user>'

Either no password is specified for scheduling jobs or the password present in the system is not valid.

To specify a password for scheduling jobs, navigate to Home -> User Preferences and provide a password.

Environment

CCS 12.x Console

Cause

Credentials required for CCS to run that scheduled job have not been set for that specific user.

Also in CCS 12.x, the location on where you add the password to CCS has changed, it is no longer in the 'Home' -> User preferences'.

Resolution

In 12.x, the location on where you add the password to CCS has changed, it is no longer in the 'Home' -> User preferences'.  It is now found in the 'Admin' -> 'Scheduled Job Management' section.

Follow the steps below to resolve the issue in 12.x

  1. Login to the CCS Application server machine as the user account referred to in the error message.
  2. Launch the CCS console
  3. In the console go to 'Admin' -> 'Scheduled Job Management'.
  4. Enter the password for the user account mentioned in Step 1 in the 'Scheduled Job Credentials' section.
  5. Re-enter the same password to confirm the password.
  6. Click 'Save' button.
  7. Schedule the job to see if the problem still exists.