Unable to install DAgent via Remote Agent Installer
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Unable to install DAgent via Remote Agent Installer

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Article ID: 151731

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

When trying to install DAgent using the Remote Agent Installer utility, one of the following errors are returned:

 1) An error occurred launching DAgent.exe. Windows reported "Logon failure: unknown user name or bad password."

 2) The interface is unknown.

 3) No network provider accepted the given network path.

Environment

GSS 3.x

Cause

The Remote Agent Installer requires Registry access on computers it installs DAgent to. In order to have access to the registry of those computers, the Remote Registry Service must be enabled and the LOCAL SERVICE user account must have read access to the HKLM\System\CurrentControlSet\Control\SecurePipeServers\winreg registry key.

Possible causes for error messages:

1) The domain name is case sensitive.

2) Port 402 is being blocked.

3) Simple File Sharing is enabled.

4) Firewall enabled on client machine. Virus protection software can also cause similar problems.

Resolution

1) Try specifying the domain name in all capital letters.

DOMAINNAME\username
password

         If not on the Domain:

              COMPUTERNAME\username
              password

         It should then authenticate correctly.

2) Layer 3 switches and routers can block or close port 402. Verify that this port is open with a utility such as TCPView from http://www.sysinternals.com.

3) Open My Computer and click on Folder options > View from the Tools pull-down menu. Scroll to the bottom of the list and uncheck the option Use simple file sharing (for Windows* XP clients).

4) Disable client computer Firewall and Virus Protection.


For ALL problems with Remote Agent Installer, test the following: 

A. Test For Network Accessability

  1. Use the Ping command from a DOS command window by using the "ping -a <client IP address> /402 from the Deployment Server. If DNS is working properly, the "-a" should resolve the Computer Name to be returned as follows:

    Pinging <Computer Name> [ip address] with 32 bytes of data. 

  2. [Failure indicates a DNS issue. For information on how to flush out old DNS entries on your computer with command: ipconfig /flushdns]

B. Local Security Policy

  1. On a target client computer, open the Local Security Policy editor from the Windows Control Panel | Administrative Tools.
  2. Navigate to Local Policies\Security Options.
  3. Change "Network Access: Sharing and Security Model for local accounts" to Classic.

C. Test For Local C$ Access

  1. From a client computer, go to Start > Run, type in \\Computername\C$ and press ENTER.
  2. This will then prompt the user for the credentials to access the drive. Enter in the credentials that are being used to push out the AClient.
  3. If the credentials do not access the C$ drive, then use the token "%COMPUTERNAME% \Administrator" to access the C$ drive.  
  4. The next step is to use the "%COMPUTERNAME% \Administrator" to push out the AClient.

D. Test For Remote C$ Access

  1. From the GSS Server, go to Start > Run, type in \\ClientComputerName\C$ and press Enter.
  2. This will then prompt the user for the credentials to access the drive. Enter in the credentials that are being used to push out the DAgent [If this results in an error, then this account does not have Remote Registry rights to this computer or the Remote Registry service is not running.]

E. Test For Registry Entry Creation Rights

  1. From the Deployment Server, go to Start > Run, type in "Regedit" and press return to launch the Registry editor.
  2. From the File pull-down menu, choose "Connect Network Registry..." and choose the target client computer. [If this action fails, the Remote Registry Service is probably not enabled on the client machine.]
  3. In the registry of the target client computer, navigate to HKEY_LOCAL_MACHINE | SOFTWARE and right-click on Altiris.
  4. Choose New > Key. [If this action fails, there is no rights to the registry.]

F. Test for Remote Services Access

  1. From the Deployment Server, go to Start > Run and type in "services.msc" to launch the Services management utility.
  2. Right click on "Services(Local)" and choose "Connect to another computer...".
  3. Choose the target client computer to connect to.
  4. Restart a service on the client computer. [If this action fails, the Remote Services are not running or functioning.]

If all tests complete without errors, the Remote Agent Installer should have no problems pushing the dagent to the remote client computer.