search cancel

Communication issues between SEP client and SEPM after installing Internet Explorer v.7 in environment using a proxy server.

book

Article ID: 151667

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

After installing IE7 on XP Pro SP3 workstations, communication between SEP MR3 client and the SEPM is lost. This is specifically in an environment using a proxy server.

Symptoms:

  • After installing IE7, no green dot on SEP icon. Server displays as 'Offline'
  • Secars test returns ‘OK’
  • Sylink.log indicates the following when connecting to SEPM IP address:

Throw Internet Exception, Error Code=997;AH: failed to end request...

EVENT_SERVER_DISCONNECTED, return=0

  • Sylink.log indicates the following when connecting to SEPM host name:

HTTP returns status code=404

  • Internet connectivity, email, and shared resources all access normally
  • Re-installing IE6 restores communication

Cause

Several possible issues:

  • Proxy settings from IE6 were not retained following install of IE7
  • Internet Options/Advanced continue to use HTTP 1.0 instead of HTTP 1.1
  • Windows Registry retains legacy setting for the following key: HKU\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections

Resolution

  • Verify proxy settings from IE6 were retained following install of IE7
  • Verify Internet Options/Advanced for IE7 include the following:

                   Use HTTP 1.1
                   Use HTTP 1.1 through proxy connections

  • Delete HKU\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections

                  Connections key is recreated at reboot

Also, it may be needed to disable the IE functionality if "autocaching" see the following article for information from Microsoft:

http://support.microsoft.com/kb/271361