search cancel

What versions of Java are compatible with Symantec Endpoint Protection for Linux?

book

Article ID: 151504

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

Installation may stop responding at sepjlu. If the installation does complete, LiveUpdate fails with error "LiveUpdate did not complete normally"

 

Cause

SEP for Linux, and the legacy SAV for Linux, are compatible only with Oracle Java and requires Unlimited Strength Java(TM) Cryptography Extension (JCE) policy files.

Resolution

Ensure Oracle JDK or JRE 1.6 or higher (1.6, 1.7, and 1.8) is installed and configured as the default java. For security purposes, Symantec recommends using the latest available when possible.

If Java is reconfigured after SEP for Linux has already been installed, the JAVA_HOME value in /etc/Symantec.conf must be updated. A system restart may be necessary.

Also ensure also that Unlimited Strength Java Cryptography Extension (JCE) policy files are used rather than limited jar policy files. If Oracle Java is installed, but the Unlimited Strength JCE has not been installed, LiveUpdate will run but not be able to download and process content.

For the latest files
Please visit http://www.oracle.com/technetwork/java/javase/downloads/index.html for the latest version of Java and the Unlimited Strength JCE files for your platform.