Perform a disaster recovery when the database backup/restore process fails using the "Database Backup/Restore Wizard" for an Embedded Database
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Article ID: 151477
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Updated On:
Products
Endpoint Protection
Issue/Introduction
How do I perform a disaster recovery when the database backup/restore process fails using the "Database Backup/Restore Wizard" for an Embedded Database?
Symptoms Database backup/restore fails through the database backup and restore wizard
Cause
Inability of the "Database Backup/Restore Wizard" to access the database to launch a backup OR a restore operation
Paste it to another storage area (as it will be deleted during Symantec Endpoint protection Manager uninstall)
Stop the services "Symantec Embedded database" and the "Symantec Endpoint Protection Manager"
Copy the "db folder" from:
\\ProgramFiles\Symantec\ Symantec Endpoint Protection Manager\
Paste it to another storage area.
ON THE NEW INSTALLATION AFTER THE DISASTER RECOVERY OF OPERATING SYSTEM (OS)
Warning: Re-installation of Symantec Endpoint Protection Manager needs to be done on the same IIS Port and Website for it restore client-server communication after the Disaster Recovery Process is complete.
Ensure that the server has the same IP Address and Host Name the Operating System has been Installed.
Install the "Symantec Endpoint Protection Manager" with the "Embedded Database" with the default settings.
Log in to the Console
Click Admin.
Select Tasks> Servers.
Under "View Servers", expandLocal Site.
Click the that identifies the local site.
Select Tasks.
Click Manage Server Certificate.
In the "Welcome panel", click Next.
In the "Manage Server Certificate panel", select Update the Server Certificate
Click Next.
Under "Select the type of certificate to import", select JKS keystore.
Click Next. Note: If one of the other certificate types has been implemented, select that type.
In the "JKS Keystore panel", click Browse.
Locate and select the backed up "keystore_.jks" keystore file.
Click OK
Open the "server_.xml" file
Select and copy the "keystore password."
Activate the "JKS Keystore" dialog box.
Paste the "keystore password" into the "Keystore" and "Key boxes." Note: The only supported paste mechanism is Ctrl + V.
Click Next Note: If you get an error message that says you have an invalid keystore file, you probably entered invalid passwords. Retry the password copy and paste. (This error message is misleading.)
In the "Complete panel", click Finish.
Stop the services Symantec Embedded database and the Symantec Endpoint Protection Manager
Go to:
\Program Files\Symantec Endpoint Protection Manager\
on the new "Symantec Endpoint Protection Manager" and rename the "Db" folder to "Db_new"