search cancel

Backward Compatibility for SMA and plug-ins

book

Article ID: 150712

calendar_today

Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

Does SMA (Symantec Management Agent) provides “backward  compatibility” ?

Environment

ITMS 8.x

Resolution

Here is some information provided by PM and QA regarding a feature called “backward  compatibility” for SMA (Symantec Management Agent) and plug-ins:

The use of this feature is intended to be a temporary state to assist customers in migrating the agents in phases.  We do not support the long-term use of the product in this state.  If a customer encounters an issue that is specific to using an older agent with a new version of the Symantec Management Platform (SMP) and that issue is not present when the agent is upgraded to the same version as the SMP, we will not fix the issue.  The solution will be for the customer to upgrade the agent to the same version as the SMP.

This feature is supported only for the two most recent major/minor versions of the agent.  For example, an ITMS 8.6 SMP will enable customers to manage devices using a 8.1 or 8.5 agent.  As mentioned, this is intended to be a temporary state to assist customers in migrating their agents because we realize that it is unrealistic for customers to upgrade all agents at once in larger environments.  Customers need to understand that they should not plan to run the product in this state for any length of time.

Also, running a newer version of the SMA connecting to an older version of the SMP (for example client machines running agent version 8.6 and the SMP is still version 8.5) is not supported. In some instances during the agent (SMA) troubleshooting, it may be suggested to upgrade just few agents to a newer version than the SMP, but this is done to test a specific fix before requesting to upgrade the whole environment to that version (for example, upgrading the agent to 8.6 RU2 while the SMP is still on 8.5 RU4 or 8.6 RU1. After checking the agent fix works, you would be requested to upgrade the SMP to 8.6 RU2 in order to be supported running the agents on 8.6 RU2). agent Plug-ins follows the same rules. 

Note:
In the case that you created a CEM Installation Package (Generating and Installing the Cloud-Enabled Management Offline Package) with a previous version of the SMA on it (like the CEM Installation package was created originally 8.6 RU1 version on it and you are upgrading to 8.6 RU2), you can still use the same package to setup new client machines. However, after you are already upgraded to 8.6 RU2 and done getting things upgraded to their newer agent and plugin versions, it is better that you create a new CEM installation package to be used on future installations. What we care is that the CEM package has the current certificates and communication profile with the necessary data to talk back to the SMP server. After installing the CEM package on those new machines, they will talk back and receive the agent upgrade policy (if it s turned on).

Note:
LAC ("Legacy Agent Communication") is irrelevant for versions of SMA greater than 7.5. LAC was used to turn on/off Communication Mode for old agents versions. This option controlled if legacy agents received secured data or not. The default state is 'OFF'.

7.5 or earlier:
1. Open the NS web Console and go to "Settings > All Settings > Notification Server > Notification Server Settings"
2. Turn on the Legacy Agent Communication policy.

7.6 and later:
Now there is a coreSetting that can be modified with NSConfigurator ("C:\Program Files\Altiris\Notification Server\Bin\Tools\NSConfigurator.exe") or under the SMP Console (Settings>Notification Server>Core Settings>Security). This setting is called "LegacyAgentCommunicationMode"