Vulnerability issues which will be addressed in SOI 4.2