Migration tool fails to migrate standalone file: Migration failed: org.jboss.migration.core.ServerMigrationFailureException: failed to parse xml file /opt/app/jboss-eap-6.4/standalone/configuration/standalone-full-ha.xml
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Article ID: 145990
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Updated On:
Products
CA Identity ManagerCA Identity GovernanceCA Identity PortalCA Identity Suite
Issue/Introduction
We encountered the following error when running the migration tool. The tool is looking to migrate over the standalone-full-ha.xml file, which we do not use. We are using the standalone-full.xml file (since we moved into a silo-style IDM installation). We need to open a ticket with CA/Broadcom support to find a way to get around this.
12:27:21,069 ERROR [logger] Migration failed: org.jboss.migration.core.ServerMigrationFailureException: failed to parse xml file /opt/app/jboss-eap-6.4/standalone/configuration/standalone-full-ha.xml
Cause
The migration fails because there is no standalone-full-ha.xml file as a source.
In the above case, the customer had an unsupported silo configuration in which multiple application servers, not clustered, pointed to the same object store. Such a silo configuration has not been supported since Identity Manager 8.x.
The supported configuration and migration script requires a valid standalone-full-ha.xml as the source
Resolution
Migration from a standalone-full.xml file is not supported. The migration script requires the source to be a standalone-full-ha.xml file under the assumption that it was originally installed and configured as a supported HA system.