CA Service Desk ManagerCA Service Management - Service Desk Manager
Issue/Introduction
When using the local browser on the given xFlow server, the xFlow interface accesses successfully, ie "http://XFLOWSERVER:9003" or "http://localhost:9002".
When using a web browser located in another domain location, which requires use of the FQDN, the same xFlow access will fail, despite the end user having entered a URL of "http://XFLOWSERVER.DOMAIN.COM:9003". The web browser console (debug tool in Firefox and Chrome) will report in the listings:
"The Same Origin Policy disallows reading the remote resource"
Same line references an attempt to access "http://XFLOWSERVER:9003". However, the given URL that is listed in the console log is situated in a different domain than the web browser and the reference should really be to "XFLOWSERVER.DOMAIN.COM".
Environment
xFlow on 17.1 and higher, xFlow server is situated on a different domain/requires FQDN access.
Cause
The given xFlow server, being in a given domain, needs to be configured to allow access via the FQDN (Fully Qualified Domain Name)
Resolution
The following two files in the xFlow server will need to be edited to change the server name from "XFLOWSERVER" to "XFLOWSERVER.DOMAIN.COM". Backup the original files first.
Once the files have been changed, save and recycle xFlow Services
Content of interest: server : 'http://XFLOWSERVER:9002' + '/api' server : 'http://XFLOWSERVER:9002' + '/bui' server : 'http://XFLOWSERVER:9006' server : 'http://XFLOWSERVER:8080/CAisd/pdmweb.exe' // - example:http://sdmurl:8080/CAisd/pdmweb.exe server : 'ws://XFLOWSERVER:9008' server:'ws://XFLOWSERVER:9014' server : 'http://XFLOWSERVER:9016'