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 Some Clarity PPM View changes such as Other Work Team view are not pushed automatically to users

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Article ID: 145870

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

  1. Some Clarity PPM View changes are not pushed automatically to users even if they haven’t customized their view.
  2. Two views this happens with are:
    • Team Object: Staff List
      • Used for NPIOs such as Other Work
    • Project Team – Detail
  3. It does not happen on all views such as the Staff List – Detail view.
  4. It appears to start happening after you publish the Team object one time. Then, any changes after that require a publish in order for the views to all be updated.

STEPS TO REPRODUCE:

  1. Go to Administration->Object->Team->Views
  2. Click on the Layout link next to ‘Staff List’
  3. Add “Default Allocation %” to Selected Columns and Save
  4. Create a new user with access that includes “Other Work – View” and “Other Work – Navigate”
  5. Log in as the new user and go to an Other Work Team tab
  6. The Default Allocation % correctly displays add an added column
  7. Log in as the Administrator, and go back to the Team object and click Publish
  8. Make another change to the Staff List view, IE add Default Allocation % (Compare To) to selected columns and Save
  9. Log back in as the user created in step 4 and view the Other Work Team tab (Note, you may have to repeat steps 7-8 a couple times to make the issue start happening)

Expected Results: User sees the most recent change to the Other Work Team list since they haven’t customized their view (Default Allocation % (Compare To)) displays

Actual Results: The most recent change doesn’t display (Default Allocation % (Compare To)) is missing

  • Note:
    • This issue also happens for new users created after the publish / after recent changes are made.
    • The latest update they see is the one prior to Publish, they won’t see the most current changes until the Team object view is Published again.

Cause

This issue is caused by: DE53646

Environment

Release : 15.5, `15.5.1, 15.6, 15.7, 15.7.1

Component : CA PPM SAAS STUDIO

Resolution

This issue is under review as DE53646

Workarounds:
  1. Have the users manually make the changes to their personal view
OR

     2. Publish the Team object view (This resets all customizations for all users for all Team views though)

The option of having the user do a "Restore Defaults" does not help with this issue.