cabi upgrade from 3.32 to 3.40 fails with "Not able to connect"
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cabi upgrade from 3.32 to 3.40 fails with "Not able to connect"

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Article ID: 145840

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction


CABI upgrade from 3.32 to 3.40 with HTTPS enabled fails with the following error in the cabi.log

[main, cabi] changing probe state from 'INITIALIZING' to 'STARTING_WASP'
[main, cabi] activating wasp...
[main, cabi] ... activated wasp  [time taken=0 minute(s) 0 second(s) (141 ms)]
[main, cabi] waiting for wasp to start...
[main, cabi] wasp has started  [time taken=2 minute(s) 47 second(s) (167431 ms)]
[main, cabi] waiting for cabi webapp @ https://cabi.test.com/cabijs to start responding ... 
[main, cabi] checking url=https://cabi.test.com/cabijs, timeAlreadyWaitedInSecs=0, maxTimeInSecs=600600
[main, cabi] Not able to connect to url=https://cabi.test.com/cabijs, timeAlreadyWaitedInSecs=0

Environment

Release : 9.0.2

Component : UIM - CABI

Cause

Cabi probe is unable to connect to the url without the port configured in the link

Resolution

Used Raw configure to changed the cabi -> setup -> cabi_url key from https://cabi.test.com/cabijs to https://cabi.test.com:443/cabijs