Jobs are blocked with incorrect "Waiting for parallel" status
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Jobs are blocked with incorrect "Waiting for parallel" status

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Article ID: 145823

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

The job in question has a setting of maxparallel = 1 and only one allowed to run at a time. Additionally, there is a post-condition check on the job on the workflow task. After one instance of the job finishes and the post-conditions check takes a bit longer, the check for running instances of the job happens before the post-condition check is finished. Consequently, it can lead that the other job instances stay wrongly in "Waiting for Parallel" status.

 

Environment

Release : 12.x

Component : AUTOMATION ENGINE

Cause

This is confirmed as a bug and will be corrected in the future releases.

Resolution


As a workaround we can propose the following:
- limit the maximum execution of the job on a queue level; The job itself has no limits on max parallel runs, but it runs in an own queue with a limit 1. In that way all other will stay in waiting for queue slot, and also start one after the other.
- limit the execution on an agent level; Set the job consumption to 1, and set the host so that it has maximum resources 1.
- use the manual release like on previous occasions

This was fixed with Automation Engine 12.2.7 and 12.3.4 - please note that an update to the automationengine component also requires an update to the utilities, initialdata, and AWI to the same service pack