Clarity : Jaspersoft reporting showing error during immediate schedule
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Clarity : Jaspersoft reporting showing error during immediate schedule

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Article ID: 145639

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

When using IBM access manager as a Load Balancer and SSO solution, the scheduled job doesn't get saved and throws and error.

Steps to reproduce

1) Go to Advanced Reporting

2) Go to View --> Repository

3) Navigate down the folders and expand the node CA PPM--> Reports --> Time Management

4) Right Click on the Resource Time Review by Manager report and select Schedule

5) Click Create Schedule

6) Schedule: Immediately, Recurrence None.

7) Parameters: Choose a Resource Manager. Leave all else as default.

8) Output: Check HTML & PDF. Uncheck all File Handling and Outputs.

9) Notifications: Place your email in the ‘To:’. Subject: Test. Check Include HTML report in email body.

10) Click Save. Provide a name for the scheduled job.

Expected Results :- Scheduled gets saved.
Actual Results :- We get a Failed to save scheduled job error mentioning Access to the selected resource or application has been denied. 

Environment

Release : 15.x

Component : CA PPM JASPERSOFT

Cause

Jasper Server uses Rest API's to perform application level operations. If there are any REST API HTTP methods that are blocked on the web server, we will run into this problem.

Resolution

This is Resolved by enabling/allowing PUT and DELETE HTTP Methods on the Load balancer/Web server configuration.