New OneClick install unable to see one of the DSS servers
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New OneClick install unable to see one of the DSS servers

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Article ID: 145629

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

We recently installed a new OneClick server. One of the DSS landscapes in the landscape map is showing unable to communicate. We have other backup OneClicks and DSS servers communicating ok. 

We enabled CORBA Communication debug on the OneClick tomcat service and we see this error in the log: 

Caused by: org.omg.CORBA.INTERNAL: The endpoint <hostname> described in the IOR profile is invalid.  vmcid: 0x0  minor code: 0  completed: No

Cause

The error "The endpoint <hostname> described in the IOR profile is invalid." is a generic error indicating a hostname resolution issue.

We use Windows etc/hosts file instead of network DNS name resolution.

Resolution


- We reviewed the Windows/System32/Drivers/etc/hosts file
- the file is correctly formatted and contains all hostnames and IP resolutions
- we compare the same file to other etc/hosts files and they appear duplicate

HOWEVER

We have noticed that the hosts file on this new OneClick machine is saved as a "text" or ".txt" file. 

The ETC/HOSTS file CANNOT be saved as a TEXT document. If it is any other doc type than generic "file" then the OS cannot read the hosts file, and hence any changes made by adding new hostnames is not being read properly

We copies a hosts file from a working server and was sure that this does NOT have .txt extension. 

Now the communication is working properly

CORRECT: 



INCORRECT: