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JasperReports fails to run reports after modifying Jasper Domain

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Article ID: 145623

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After modifying Jasper Domain any try to run a report fails and in the ServiceDesk stdlog files we can see the following error:

domsrvr 7496 ERROR sec_mgr.c 4030 Unable to find DomSession 117783223 used by user caadmin invoked by dal_jdbc_driver_hostnameI with reply method prepare_sqlquerynnn

Cause

While editing the Jasper Domain, the back-end ODBC connection established to run reports timed out.

Currently, there is no way to reconnect automatically the ODBC/JDBC connection once the connection has timed out.

Environment

Release : 17.2

Component : JASPERSOFT REPORTS FOR SERVICE MANAGEMENT

Resolution

1. Increase odbc/jdbc timeout on ServiceDesk

In order to increase the odbc timeout from default 60 min to 120 min, follow steps:

- Save current  NX_ROOT\bopcfg\www\web.cfg file.

- Within the file, do the following change (be aware that the value is in minutes) :

             from :

             ! OdbcTimeout 60

             to :

             OdbcTimeout 120

- for the change to take effect, the CA Service Desk service needs to be restarted.

2. Increase timeout on JasperServer

- WEB-INF/jasperserver-servlet.xml in the JasperSoft Apache Tomcat folder.

Modify below property/line to a larger value.

    from:

<property name="lockTimeoutSeconds" value="90"/>

     to:

<property name="lockTimeoutSeconds" value="180"/>

- for the change to take effect, JasperReports services need to be restarted.

Additional Information

See the following article for steps to retain the change when doing a pdm_configure :

https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=18543