Probe fails to start after UIM 8.51 upgrade to v9.0.2 with Windows Authentication enabled

book

Article ID: 145578

calendar_today

Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

The following probes fail to start after upgrading UIM 8.51 to 9.0.2; maintenance_mode, sla_engine and discovery_server (discovery_server starts but fails after some time)

Data_engine .log starts up fine but shows the following errors:

2) ExecuteNoRecords [Microsoft OLE DB Provider for SQL Server] Incorrect syntax near 'go'.

0 de: COM Error [0x80040e14] IDispatch error #3092 - [Microsoft OLE DB Provider for SQL Server] Incorrect syntax near 'go'. 

COM Error [0x80040e14] IDispatch error #3092 - [Microsoft OLE DB Provider for SQL Server] Could not find stored procedure 'spn_bas_VerifyFeature'.

QoSInsert::VerifySettings - error: [COM Error [0x80040e14] IDispatch error #3092 - [Microsoft OLE DB Provider for SQL Server] Could not find stored procedure 'spn_bas_VerifyFeature'.] sp: [ spn_bas_VerifyFeature ]

Cause

The UIM 9.02 upgrade was executed with user that does not have all of the required permissions.

Environment

Release : 9.0.2

Component : UIM - INSTALL

Resolution

Rerun the UIM install, setupCAUIMServer.exe, with the designated Windows user per the UIM install guide - Microsoft SQL Server Log in Requirements

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/9-0-2/installing/install-uim-server.html