403 message when trying to use Performance Center Rest
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403 message when trying to use Performance Center Rest

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Article ID: 145572

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

I went to go to the PM REST interface, but was met with some 403 authorization errors.  I can manually navigate to the /pc/center URL, but as soon as I try to go any deeper than that it blocks me.  My account is set up as an administrator in PC.  I did find these messages in the wrapper log:

INFO   | jvm 1    | 2020/02/20 12:28:16 | ERROR | qtp1015462025-608074     | 2020-02-20 12:28:16,014 | com.ca.im.portal.services.util.BasicAuthInterceptor              

INFO   | jvm 1    | 2020/02/20 12:28:16 |       | HTTP 403: User=user, enabled=true, requestURI=/pc/center/webservice/groups

INFO   | jvm 1    | 2020/02/20 12:28:22 | INFO  | qtp1015462025-608074     | 2020-02-20 12:28:22,419 | com.ca.im.portal.api.services.item.GroupTableCache               

INFO   | jvm 1    | 2020/02/20 12:28:22 |       | Clearing out the Group Table cache...

INFO   | jvm 1    | 2020/02/20 12:28:22 | INFO  | qtp1015462025-610326     | 2020-02-20 12:28:22,437 | com.ca.im.portal.api.services.item.ItemCache                     

INFO   | jvm 1    | 2020/02/20 12:28:22 |       | Calling refreshItems for 1 items: [6632284]

INFO   | jvm 1    | 2020/02/20 12:28:23 | WARN  | qtp1015462025-608074     | 2020-02-20 12:28:23,898 | org.apache.cxf.transport.servlet.ServletController               

INFO   | jvm 1    | 2020/02/20 12:28:23 |       | Can't find the the request for https://PC:8182/pc/center//'s Observer 

INFO   | jvm 1    | 2020/02/20 12:28:26 | ERROR | qtp1015462025-605774     | 2020-02-20 12:28:26,754 | com.ca.im.portal.services.util.BasicAuthInterceptor              

INFO   | jvm 1    | 2020/02/20 12:28:26 |       | HTTP 403: User=user, enabled=true, requestURI=/pc/center/webservice/users

INFO   | jvm 1    | 2020/02/20 12:28:30 | WARN  | qtp1015462025-605911     | 2020-02-20 12:28:30,821 | org.apache.cxf.transport.servlet.ServletController               

INFO   | jvm 1    | 2020/02/20 12:28:30 |       | Can't find the the request for https://PC:8182/pc/center//'s Observer 

INFO   | jvm 1    | 2020/02/20 12:28:34 | INFO  | qtp1015462025-608074     | 2020-02-20 12:28:34,643 | com.ca.im.portal.api.services.item.GroupTableCache               

INFO   | jvm 1    | 2020/02/20 12:28:34 |       | Clearing out the Group Table cache...

INFO   | jvm 1    | 2020/02/20 12:28:34 | INFO  | qtp1015462025-610422     | 2020-02-20 12:28:34,683 | com.ca.im.portal.api.services.item.ItemCache                     

INFO   | jvm 1    | 2020/02/20 12:28:34 |       | Calling refreshItems for 3 items: [147726, 6632283, 6632284]

INFO   | jvm 1    | 2020/02/20 12:28:47 | INFO  | qtp1015462025-610663     | 2020-02-20 12:28:47,251 | com.ca.im.portal.api.services.item.GroupTableCache               

INFO   | jvm 1    | 2020/02/20 12:28:47 |       | Clearing out the Group Table cache...

INFO   | jvm 1    | 2020/02/20 12:28:47 | INFO  | qtp1015462025-610422     | 2020-02-20 12:28:47,289 | com.ca.im.portal.api.services.item.ItemCache                     

INFO   | jvm 1    | 2020/02/20 12:28:47 |       | Calling refreshItems for 2 items: [6632283, 6632284]

Environment

Dx NetOps Performance Management

Cause

User must be a local Performance Center user, in order to access Performance center rest

Resolution

use a local Performance Center user, that has the administrator role; or use the user "Admin"