ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Rally - API call failed with http status 302, the document has moved ...

book

Article ID: 145544

calendar_today

Updated On:

Products

CA Agile Central SaaS (Rally)

Issue/Introduction

A customer's REST call just 'failed' and returned an http status 302


GET request:

https://rally1.rallydev.com/slm/webservice/v2.0/hierarchicalrequirement?workspace=https://rally1.rallydev.com/slm/webservice/v2.0/workspace/00000000&query=(FormattedID = US1234)&fetch=true

 

 Response body:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

<html><head>

<title>302 Found</title>

</head><body>

<h1>Found</h1>

<p>The document has moved <a href="https://rally1.rallydev.com/unavailable/">here</a>.</p>

</body></html>


Rerunning the call 30 min later same exact command succeeded.

What is the cause of the 302?

Cause

Usually a 302 can be caused by a server restart or failure of Java to respond.  There is nothing the customer can do to avoid this and very little Rally can do either, the issue is very rare.

Environment

Release : SAAS

Component : AGILE CENTRAL

Resolution

A retry of API call was successful after the initial 302 response.