CA API Gateway: Scheduled Tasks Suddenly Stop Working
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CA API Gateway: Scheduled Tasks Suddenly Stop Working

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Article ID: 145409

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Updated On:

Products

CA API Gateway API SECURITY CA API Gateway Precision API Monitoring Module for API Gateway (Layer 7) CA API Gateway Enterprise Service Manager (Layer 7) STARTER PACK-7 CA Microgateway

Issue/Introduction

Under some circumstances Scheduled Tasks created with the Manage Scheduled Tasks function in the CA API Gateway Policy Manager do not function correctly or require a higher Thread Count to run consistently. 

Environment

Release : 9.x

Component : CA API Gateway

Cause

The possible cause of this issue may be due to the default Thread Count used by the Scheduler being too low

Resolution

In scenarios where the Scheduled Tasks stop functioning or are not consistently running, do the following:

  1. Disable the current Scheduled Task(s) that are not functioning properly and recreate the Scheduled Task with a fresh job. 
  2. Increase the Number of worker threads for the Scheduler with the scheduledTask.maxThreads Cluster Wide Property. In your Gateway Policy Manager Go to Tasks --> Global Settings --> Manage Cluster Wide Properties and add the scheduledTask.maxThreads with a value of 20. Some trial and error may be necessary to properly size the Threads depending on your Scheduled Tasks load.

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