Service point gets stuck when loading Catalog forms
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Service point gets stuck when loading Catalog forms

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Article ID: 145406

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Service Desk Manager

Issue/Introduction

Service Point hangs or does not load when accessing a Catalog form.

Seeing in the browser console "CA_Catalog is not defined".

Environment

Release : 17.3 and later releases

Component : SERVICE DESK MANAGER / Service Point / Service Catalog

Cause

cause 1: The casc_endpoint option under xFlow Interface > General is populated with a wrong URL (ie: http://<catalog_hostname>:port/usm/wpf)

cause 2: xFlow is configured with SSL and catalog is not, or vice versa (xFlow is not configured with SSL, Catalog is configured with SSL).  

Note:  if xFlow AND Catalog are both setup as non-SSL, the integration should work.  The issue arises with the browser blocking mixed content (where one source contains SSL content and another source is not SSL)

Issue may occur when updating or migrating Service Management for an RU update which may reset options or SSL configurations.

case 3: Service Catalog does not start

Resolution

Solution 1:  Adjust option for casc_endpoint

The casc_endpoint option under Administration > xFlow Interface > General overrides the casc_endpoint option under Administration > Options Manager >  CA Service Catalog.

If the casc_endpoint option under Administration > Options Manager >  CA Service Catalog is populated (ie: http://catalog_hostname:port/usm/services) and installed properly, then there is no need to configure casc_endpoint option under Administration > xFlow Interface > General and it can be set to inactive. 

Steps:

1. Log into SDM > Administration > xFlow Interface > General > Search for %casc% (By default is set to inactive)
2. Click on casc_endpoint > Edit > Inactive
3. Restart xFlow Services.

 

Solution 2:  Review SSL configuration

Implement Catalog with SSL and configured in casc_endpoint in SDM to point Catalog SSL URL:

For xFlow, configure to use SSL, please review this link.

 

Solution 3: Start the Service Catalog

Additional Information

One can also test the URL "http://<catalog_hostname>:port/usm/services" directly on a web browser.  This is an example of what should appear when one runs this URL (no logins required)