Unable to open Jaspersoft Studio error: "The platform metadata area could not be written"
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Unable to open Jaspersoft Studio error: "The platform metadata area could not be written"

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Article ID: 145344

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Cannot launch Jaspersoft studio. You. get the following error when you try to start it:

eclipse.buildId=unknown

java.version=1.8.0_151

java.vendor=Oracle Corporation

BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_CA

Command-line arguments:  -os win32 -ws win32 -arch x86_64 -data @noDefault

 

!ENTRY org.eclipse.osgi 4 0 2020-02-18 09:46:14.085

!MESSAGE Application error

!STACK 1

java.lang.IllegalStateException: The platform metadata area could not be written: X:\JasperSoftWorkspace\.metadata.  By default the platform writes its content

under the current working directory when the platform is launched.  Use the -data parameter to

specify a different content area for the platform.

at org.eclipse.core.internal.runtime.DataArea.assertLocationInitialized(DataArea.java:61)

at org.eclipse.core.internal.runtime.DataArea.getStateLocation(DataArea.java:129)

Environment

Release : Any

Component : CLARITY JAPSERSOFT

Cause

There may have been a corruption of the existing workspace folder.

Resolution

Generate a new metadata folder (e.g. under the C:\Users\Administrator\JaspersoftWorkspace\.metadata, but this depends on where you specified your workspace directory)

To generate a new metadata folder:

  1. Rename / move the folder
  2. Attempt to start JasperStudio.

IMPORTANT: This will delete all your settings, servers, and connections.

Additional Information

See also: Jaspersoft / reports known issues with Clarity