Adminui integration with AD (external administrator) on SiteMinder R12.8.3
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Adminui integration with AD (external administrator) on SiteMinder R12.8.3

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Article ID: 145270

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) SITEMINDER

Issue/Introduction

Environment

Release : 12.8.03

Component : SITEMINDER -ADMINUI

Cause

There is a problem with AdminUI for importing Root CA Certificate(or any certificate) while configuring AD connector on R12.8.3.
Nothing is logged in the server.log



Resolution

Please perform the following workaround.

1. Shutdown AdminUI

2. Copy your Root CA certificate to AdminUI server. (I saved it in BASE64 format)


3. open a cmd at "<AdminUI>/standalone/configuration


4. run "keytool -list -keystore trustStore.jks"

    See if there are any CA certificates there. If it is a new deployment it may be empty.


5. run "keytool -import -trustcacerts -alias <give it a name> -file <filename of your root ca cert> -keystore trustStore.jks"
    At the prompt for keystore password, enter "changeit" which is default.




6. Startup AdminUI and try again.
Click "Show Certificates" and only enter the Root CA Certificate "Alias" which you set during manual import.
Enter the username as "username@domainname"
 




7. It should continue to the next screen.