Tomcat AWI log: Warning message that the Java version is not supported

book

Article ID: 145222

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation CA Automic Operations Manager CA Automic Oracle

Issue/Introduction

AWI log shows WARN message saying Adopt OpenJDK 11 is not supported although it has been announced compatible by Compatibility Matrix and specifically mentioned by our Online Documentation.
Error message:
[WARN ] NOSESSION/- NOUI [webui.logback.util.RuntimeIdentification] - This Java version 'https://adoptopenjdk.net/11.0.6 ({2})' is not supported. You should be using a supported version.

Cause

The observed logfile entry is a bug in AWI, but except the warning message there is no impact at all.

Environment

Release : 12.3

Component : AUTOMIC WEB INTERFACE

Resolution

This message is removed from the following versions:
  • Automic.Web.Interface 12.4.0 (planned release 2020-09-30)
  • Automic.Web.Interface 12.3.2 (planned release 2020-02-24)