If you recently deleted a device from NFA and the device does not show back up in Enable Interfaces within a few minutes and you know data is incoming.
Cause
An issue can occur where a device is deleted out of the database but not the memory cache in the harvester process.
Environment
Component : NQRPTA - REPORTERANALYZER
Resolution
Simply restart the "CA NFA Harvester Service" on the harvester which the device is pointed to.